PDA

View Full Version : QNAP - Spindown HDD donīt work with Dune Prime 3.0


rudku
17-10-10, 16:23
Iīm bother with spindown of HDDs from upgrade to FW versions 3.3.x (3.1.1 -> 3.3.1 -> 3.3.2 -> 3.3.3).
Sometimes spindown of HDDs works without problem, sometimes donīt works ever.
I spent a lot of time for finding what causation this problem.

... and I find it: mediaplayer HDi Dune BD Prime 3.0 (FW 100916_2027_beta)

... run playback mediafiles from NAS, then go Power on Dune mediaplayer to Stanby:

- connection via nfs: after Standby of Dune spindown always works

- connection via SMB: after Standby of Dune spindown never works - only full power off Dune helps solve this problem.

I reported about this problem on QNAP forum too:
http://forum.qnap.com/viewtopic.php?f=160&t=35468&p=156118#p156118

What is your experience? Do you have a similar issue?

Malignant
18-10-10, 08:50
Did you check your Qnap logs ?

After looking at your post i suspect the dune doesn't disconnect from the NAS if SMB is used.
If the Dune goes in standby but leaves the SMB connection with the NAS "open" the NAS will never spindown.

Haven't looked at it myself but is there an option to let connections "time out" after a certain time of inactivity on the NAS maybe ?
If the NAS can terminate the idle connection it should spindown properly.

Using NFS myself and the discs always spin down for me.

rudku
18-10-10, 14:07
If the Dune goes in standby but leaves the SMB connection with the NAS "open" the NAS will never spindown.

Ya, I find this issue and you confirm it.


Haven't looked at it myself but is there an option to let connections "time out" after a certain time of inactivity on the NAS maybe ?
If the NAS can terminate the idle connection it should spindown properly.


Better way is fix this issue, such as looking for replacement solution.

Question is, if with this issue is affected only Dune or some other devices too. Iīll test it.
If only Dune - issue is on HDi side in their Dune FW.
If we find another device with this issue - then problem is on QNAP side.

Malignant
18-10-10, 14:48
I suspect this issue comes from the Dune.

This has to do with the way the unit goes into standby.
When the Dune goes into stand-by the network connection can't be terminated because some users have an internal HD in the player which must be accessable during standby to FTP data over.

So the network connection can't be terminated.
What can be done is let active connections time out from the dune side, this way the connection will get dropped. I suspect they just overlooked this in the FW settings from the Dune ( or do we have the option to set this somewhere ? )

rudku
18-10-10, 18:28
If youīre right, that on Dune 3.0 "network connection can't be terminated", then will be better if HDi add new item in Network Settings:
- Switch Off network SMB connection during Power Standby: On vs. Off

Iīm try looking on NAS setting for terminating of connection, but I find only this one in Security card: (... and this is not a this one, which do you mean in post above...)

Malignant
20-10-10, 12:40
Got some info regarding this from some other Qnappers.

The problem does not only occur with Dune players, Qnaps own media players will cause the same problem. They are aware of this and hopefully this issue will be adressed in the next upcoming FW release ( due approximately next week ).

Otherwise there is a way to adress this.
If you telnet into the NAS there should be a "smb.conf" file there with the SMB settings in it.
Here you can add the following comment :
deadtime (G)

The value of the parameter (a decimal integer) represents the number of minutes of inactivity before a connection is considered dead, and it is disconnected. The deadtime only takes effect if the number of open files is zero.

This is useful to stop a server's resources being exhausted by a large number of inactive connections.

Most clients have an auto-reconnect feature when a connection is broken so in most cases this parameter should be transparent to users.

Using this parameter with a timeout of a few minutes is recommended for most systems.

A deadtime of zero indicates that no auto-disconnection should be performed.

Default: deadtime = 0

Example: deadtime = 15

NOTE : Deadtime command only works if there are no open file's on the session ! I don't know if the dune actually "closes" the files on stand-by. And in some cases certain equipment tries to reconnect after a deadtime command. I don't know how this is implemented on the dune.

Try to add a deadtime command with timer of a few minutes to the config file, reboot NAS and try if it works.

Hope this is of some help

dvbuljan
20-10-10, 13:55
I'm dealing with a same problem wit my Syno 207+. It is connected to my router. Dune and PC are also connected to the router. Reading posts on Syno forum I sistematicaly eliminated Dune. When I disconnect PC from router my Syno goes to sleep right away. So the PC is the one to blame. What is it exactly I must find out. Some sasys it is the netBIOS TCP/IP packages. I dissabled it but there's still no hibernation. I tried to use Wireshark and Process Explorer but I'm lost. :(

rudku
27-11-10, 22:17
Got some info regarding this from some other Qnappers.

The problem does not only occur with Dune players, Qnaps own media players will cause the same problem. They are aware of this and hopefully this issue will be adressed in the next upcoming FW release ( due approximately next week ).

Otherwise there is a way to adress this.
If you telnet into the NAS there should be a "smb.conf" file there with the SMB settings in it.
Here you can add the following comment :


NOTE : Deadtime command only works if there are no open file's on the session ! I don't know if the dune actually "closes" the files on stand-by. And in some cases certain equipment tries to reconnect after a deadtime command. I don't know how this is implemented on the dune.

Try to add a deadtime command with timer of a few minutes to the config file, reboot NAS and try if it works.

Hope this is of some help

I look on smb.conf in my NAS with FW 3.3.6 - still issue with no spin down after SMB connection from Dune.
I find command deadtime in [global] group settings by default:
deadtime = 10

So, I mean, that solution of this issue is on HDi side.

rudku
13-12-10, 01:07
Tested with latest FWs:

- Dune Prime 3.0: dune_firmware_bdprime3_101203_2124_test.dff
- QNAP: 3.3.6 Build1110

Dune setting: - new setup for SAMBA server = disabled
(Settings/Applications/SMB Server/Enabled=No)

Test results:
Any change - connection via SMB: after Standby of Dune spindown never works - only full power off Dune helps solve this problem.

So maybe only Malignant's proposal will help us solve this issue:

What can be done is let active connections time out from the dune side, this way the connection will get dropped. I suspect they just overlooked this in the FW settings from the Dune ( or do we have the option to set this somewhere ? )