PDA

View Full Version : help: yadis won't play / network will play


six3323
21-06-11, 13:02
Hi everybody,

i'm a bit confused.

My whole yadis movies works and they start direct from yadis menu.

... now ... the mysterious begann ...

I have a mkv movie which ich complete scraped in yadis ... but yadis sayed that it can't play 'cause of the format. ... Ok, i know this error from a few files in the past ... and normaly a mux in mkvmerge solved the problem.

... but ... yadis will not play this mkv ... in spite of remux

... if i go in the dune menu direct over the network and start the mkv ... the dune hd smart play the mkv without any error message or problems.

I always connect via smb ... and i have no declaration why this movie won't work via yadis ... but over network.

I thought yadis makes only a link via smb to the file ...

I hope anyone can explane this to me.

thanks

six3323

flugs
21-06-11, 21:30
Salut,

if you say "from yaDIS", do you mean with the remote control feature of yaDIS (play/stop/pause button in the yaDIS application on your PC)?
If this is the case, which version are you using (2.05/2.1x)?

Version 2.05 had problems if there were special characters (example "&") in the filename. This has been announced to be fixed in 2.1 (not tested until now).

A+
flugs

six3323
22-06-11, 14:22
No, i don't mean the remote control on my pc.

I mean yadis on my Dune HD Smart ... the programm surface where i cant see the covers and details ... and where i can start playing the movies.

Here (yadis on my Dune) the movie won't be played with the error message "wrong /unknown format".

The funny / mysteriuos thing ... if i go on my Dune HD over network (smb share) in the moviel folder ... i can start and play the movie correct.

This is what i don't understand. If the format of the mkv movie is wrong, why can it be played over network ... and not in yadis?

flugs
22-06-11, 16:27
Salut,

I think it would be helpful if you send some more details (especially filenames).
As far as I understood, the Dune is creating a playlist from the yaDIS interface (including the single file) and executes this playlist. Possibly there are special reserved characters involved, which are in your filename (as mentioned before this happened with the remote and I got the same message when this happened). This also would explain why you only have one single file where you get this error.

A+
flugs

six3323
22-06-11, 16:44
The Filename contains no special character's (like , , /, (, _, etc.) only 1 blank netween the two words.

example:
my movie.mkv

I'm not sure ... but why he should create a playlist? ... It's only 1 mkv file.

I'm realy confused :confused:

flugs
22-06-11, 17:32
Salut,

nothing to be confused.
This is internal Dune handling.
My interpretation is that yaDIS creates a structure of shortcuts and Dune needs to create a "playlist" of a single file to execute the shortcut.
(I only suppose it is the way it is handled, but could be wrong).

It seems you do not want to post your exact filename, but have you tried to rename your file (or/and copy to another location)?

There must be something different between the file(s) which are working and the one, which is not. The more information you send the higher the possibility somebody will find this difference.

A+
flugs

six3323
24-06-11, 13:40
I don't know, if dune creates a playlist if there is only one file.

But i think the procedure should be the same as the start via network on the dune surface.

In the dune file is the standard smb path correct ... an via network the dune should do the same ... ?

like smb://myserver/videos/movies/mymovie1.mkv

I can't realy understand where's the diffrence between, to start the movie via yadis oder network.

flugs
24-06-11, 15:04
Salut,

You will have to ask HDI why they are creating a playlist for a single file, but yaDIS only uses a documented functionality of the Dune file browser (based on Dune_Folder.txt. You can obtain additional information on the HDI website) to create the interface.

It is similar to Windows shortcuts, where a file (.lnk) contains information about the link (in the case of yaDIS and Dune it is the Dune_Folder.txt file).


Have you tried to create a shortcut on the main-screen of the Dune for your movie (browse to your movie, popup menu, Add to Favorites (do not know the exact name of menu-item)).

Switch of Dune, restart and try to start your movie from the shortcut.


If this is working compare the information from the created shortcut (popup-menu, information) with the one you can find in the Dune_Folder.txt file generated by yaDIS for this movie.


A+
flugs

six3323
24-06-11, 16:55
Ok, i already made a test.

I added a shortcut from the movie over network to favorits
The info of the shourtcut was: smb://user: pass@myserver/videos/movies/my movie1.mkv
> The mkv was played correct by the Dune !

I checkt the yadis file dune_folder.txt:

item.0.media_url=smb://myserver/videos/movies/my movie1.mkv

After i added the direct shortcut to the favorits and tryed to start the movie (movie was played correct) ... i went back to yadis and tryed to start the movie.
ERROR ... an the Dune reboot automatic

After i deleted the direct shortcut from favorits ... and went back to yadis ... "Unknown format" ... and yadis didn't play the movie.

flugs
24-06-11, 17:46
Salut,

could you please confirm other movies on the same share are working?
Do you need credentials to access your share (I do not know, if pass@myserver is automatically generated when creating the shortcut)?

Have you made a test with Zappiti (uses the same technology to generate the Dune interface).

Otherwise I do not have any more ideas and can only repeat that I believe this is a problem somewhere in Dune/Network/Share, but not a problem of yaDIS.

A+
flugs

six3323
24-06-11, 18:04
Other movies works fine with yadis and the dune_folder.txt also looks like
item.0.media_url=smb://myserver/videos/movies/my movie1.mkv

No i made one more test ... and edited in yadis / options the smb path with the user and pass of myserver.

now dune_folder.txt looks like:
item.0.media_url=smb://user: pass@myserver/videos/movies/my movie1.mkv

... and the movie woks ...

I did not know that yadis need the user and the pass ... what i don't understand is that all the other movies works with the old smb path (withou user and pass) ... and this one didn't.

Anyway ... i would like to understand ...

flugs
24-06-11, 18:21
Salut,

So it is already better than before and I understand that you want to understand, but once again it is not yaDIS which needs this, it is Dune in combination with the share which needs this.

Have you checked the configuration of the movie? Does "anyone" have access or (for any reason) is the access restricted.

Happy the general functionality seems to work and I hope you will find the reason why it behaves like this (even, if I think you would need to focus on the Network/Share/Dune and you would need to deliver much more details to get additional help).

A+
flugs

six3323
24-06-11, 18:25
Thanks ... i will check my network rights at the weekend ... and give a feedback