PDA

View Full Version : Failed to open url - if dune interface location is on server


lasers
23-11-11, 23:31
I've been setting up yaDIS, for my movie collection. Everything has been scrapped but I've runned into a problem. I'm pointing the dune interface location to a folder on my file server, I can browse my movies through yadis (dune hd1), but when I'm trying to play a file, it says that the url is wrong. I've double checked the path and it's fine, also tried with user:password etc, it just won't work. (It does work though if I use yaDIS remote function and press play).

But here is the funny thing. If i press pop-up menu on the remote, select add to favorites and start the movie through the favorites menu on the dune, it works without me changing anything (I can see that the file path is exactly the same).

So I kept trying for a while, copied my exported folder to a usb stick, plugged it into the dune d1 and that worked, _not exporting it again_, just copying the EXACT same files that is on the server (where the URL doesn't work).

I've also copied it to my workstation, shared a folder and voila, it works from here to.

Plugged in a second usb to my dune just now, changed dune interface location to it, exported my library again - and it works.

I've tried it in two different shares on the server - same problem on both. What I do also find strange is that, when the dune interface location is on the server, it changes the way yaDIS works, if I browse to a movie and press "enter" it just opens the background.jpg - not the "play media / show photo menu" that appears if I press enter when the "dune interface location" is on a working location.

Can someone please help me, I'm trying to consolidate as many functions as possible to my file server, and the usb connected to the dune is far slower than using the server.

Fred-L
23-11-11, 23:40
The Dune is not able to open 2 smb connections at the same time. With your setup, the Dune opens a smb connection to access the yaDIS's interface. Another one is needed to launch a movie. It cannot work with this limitation of the player.
The solution is to access the interface via a nfs connection. This way, a movie can be launch using a smb connection. Or you can do the opposite: smb for the interface and nfs for launching movies.

lasers
24-11-11, 18:26
The Dune is not able to open 2 smb connections at the same time. With your setup, the Dune opens a smb connection to access the yaDIS's interface. Another one is needed to launch a movie. It cannot work with this limitation of the player.
The solution is to access the interface via a nfs connection. This way, a movie can be launch using a smb connection. Or you can do the opposite: smb for the interface and nfs for launching movies.

Thank you for your answer, you were correct. I took me a while to figure out how to configure NFS on unraid and on my dune, but now it works. Thank you so much!

craigr
30-11-11, 00:53
Wow, this thread is exactly what I needed. Been using yaDIS for over a year with a USB flash on the DUNE. Got another DUNE and wanted to switch the interface location to the NAS and no go... I have the same SMB limitation.

Thanks guys!
craigr

craigr
02-12-11, 19:43
Is there a way to add yaDIS to the DUNE "favorites" with yaDIS located on an NFS share... and have it work?

I mean, I can add yaDIS to the favorites and it works right after adding it there. However, when I reboot the DUNE and try the NFS favorites yaDIS again, I get an error that it "Failed to open url."

But, if I go to the "Sources" page, and through the network NFS folder I can open yaDIS and then if I go back to the favorites yaDIS it will also open.

I also made an NFS folder directly to yaDIS that works. However, I don't like this as much because the folder cannot be added to favorites and the yaDIS icon is not used (network folder icon instead). ie when I clike the network folder yaDIS starts directly.

Thanks,
craigr

Sjonnie
03-12-11, 07:39
Hi craigr,

Looks like the connection to the NFS share has to be verified first on your Dune. Which is strange!:confused: I have yaDIS on my NAS (in the same rootfolder as the media files) and I can always access yaDIS from favorites.

Can you tell me what the NFS path looks like on your Dune?

Can you also check if the NFS privileges on your NAS are setup OK?

BTW What make and model NAS do you have?

Greetz,

Sjonnie

ScottJ97
06-12-11, 20:49
Is there a way to add yaDIS to the DUNE "favorites" with yaDIS located on an NFS share... and have it work?

I mean, I can add yaDIS to the favorites and it works right after adding it there. However, when I reboot the DUNE and try the NFS favorites yaDIS again, I get an error that it "Failed to open url."

But, if I go to the "Sources" page, and through the network NFS folder I can open yaDIS and then if I go back to the favorites yaDIS it will also open.

I also made an NFS folder directly to yaDIS that works. However, I don't like this as much because the folder cannot be added to favorites and the yaDIS icon is not used (network folder icon instead). ie when I clike the network folder yaDIS starts directly.

Thanks,
craigr

I solved this problem a few weeks ago on another forum. Start here. (http://www.avsforum.com/avs-vb/showthread.php?p=21196293#post21196293)

I consider it a bug of the Dune; it doesn't make the proper URL in favorites, and then it's unable to mount the share the next time. But you can hack it up if you're comfortable with a Unix command-line: edit a file under /persistfs/main_screen_items to add another colon in the right place.

craigr
07-12-11, 23:50
Hi craigr,

Looks like the connection to the NFS share has to be verified first on your Dune. Which is strange!:confused: I have yaDIS on my NAS (in the same rootfolder as the media files) and I can always access yaDIS from favorites.

Can you tell me what the NFS path looks like on your Dune?

Can you also check if the NFS privileges on your NAS are setup OK?

BTW What make and model NAS do you have?

Greetz,

Sjonnie
Thanks for your help and the fact that you have it working gives me an idea based on your follow up questions. I do not have "guest" access for NFS shares setup on my NAS, so I think I will try this.

The path is very simple and is just

/yaDIS/yaDIS

as I have a share called yaDIS with a folder called yaDIS off the root.

The NAS is a Netgear ReadyNAS NV+.

Thanks again,
craigr

craigr
07-12-11, 23:51
I solved this problem a few weeks ago on another forum. Start here. (http://www.avsforum.com/avs-vb/showthread.php?p=21196293#post21196293)

I consider it a bug of the Dune; it doesn't make the proper URL in favorites, and then it's unable to mount the share the next time. But you can hack it up if you're comfortable with a Unix command-line: edit a file under /persistfs/main_screen_items to add another colon in the right place.
I think you are dead on with this. I noticed a day or two ago that there is a colon missing in the URL when I look at the link under info...

Don't know if I feel like hacking, but I'll have a look at your post.

Thanks,
craigr

ScottJ97
08-12-11, 00:02
Thanks for your help and the fact that you have it working gives me an idea based on your follow up questions. I do not have "guest" access for NFS shares setup on my NAS, so I think I will try this.


That won't help. If you can access it from the network folder, then permissions are fine. Accessing it through a favorite doesn't do anything different with the permissions.

The problem occurs when the Dune tries to first mount the share. Mounting from a network folder works; mounting from a favorite doesn't work. Once it is mounted, accessing it from either place works.

It happens to work for some people because the Dune correctly guesses the share path. For other people it guesses incorrectly.

See my link above for an ugly way to solve this. [Edit: sorry, posted before I saw your reply above.]

craigr
08-12-11, 01:56
That won't help. If you can access it from the network folder, then permissions are fine. Accessing it through a favorite doesn't do anything different with the permissions.

The problem occurs when the Dune tries to first mount the share. Mounting from a network folder works; mounting from a favorite doesn't work. Once it is mounted, accessing it from either place works.

It happens to work for some people because the Dune correctly guesses the share path. For other people it guesses incorrectly.

See my link above for an ugly way to solve this. [Edit: sorry, posted before I saw your reply above.]
Hey, I went to your link on AVS and read several helpful posts... but there are lots of conversations going on in that thread and I don't know if I saw everything or not :-?

It's been like 12 years since I have had to telnet to unix so I am very rusty... I started the telnet service on the dune and setup hyperterminal to connect. I have gotten to the /persistfs/main_screen_items directory and done ls -l. I can see the yaDIS directory, but I can't for the life of me figure out how to edit it. I know what the url needs to be, but I can't figure out how to view or open the text in this shell to edit in the correct url.

Any direct tips?

Thanks,
craigr

craigr
08-12-11, 02:15
OK duhhh...

I am now in the yaDIS directory and see the dune_folder.txt file

Let's see if I can edit it ;)

craigr

craigr
08-12-11, 02:51
SWEET :D

I got it!

Used vi to edit the dune_folder.txt and inserted the ":" and after a power cycle the favorite works with NFS.

Thanks for pointing me in the right direction!

craigr

ScottJ97
08-12-11, 06:38
Glad you got it working. I added a new page on my wiki for this: Fixing NFS Favorites (http://scottjohnson.org/wiki/Dune/Fixing_NFS_Favorites).

kiskis
08-12-11, 08:29
I have the same issue, but with SMB and Dune interface location is in Dune internal HDD.

Sometimes yaDIS can play movies from my Qnap server and sometimes path is not accessible :???:.

It is very annoying.
I donīt even use shortcut launch from dune favorites.
In my case yaDIS folder is in Dune internal HDD and I launch movies from there.

Sometimes movies can be launched and sometimes not.
There is one thing, that I saw when yaDIS will not be able to access thru SMB path to movies.
When I start movie from yaDIS, then suddenly something crashes , so Dune writes on display "restart"
and after that yaDIS will not be able start movie.
I tried also with NFS but also with no luck.

Yadis - NFS transfer with NAS (http://www.mpcclub.com/forum/showthread.php?t=27808)

Using Qnap NFS on YaDIS? (http://www.mpcclub.com/forum/showthread.php?t=27235)