PDA

View Full Version : New Yadis? Or is it my Dune?


woojen
04-03-12, 17:44
Upgraded to Yadis 2.2, and now I can't watch movies anymore.

To be more specific: I can view series, but I cannot view movies.
I can see the video wall, but selecting a movie (which ususlly gets you the details of this movie) dies in an error claiming it cant find this-and-this directory.

I run a Dune Base 3.0, latest (beta) firmware. Both movies and series as well as the index are on my NAS. I access the Index through nfs and the actual movies and series are accessed through smb (I am aware of the Dune limitation of maximum one SMB connection at any given time)

I started out with the last stable firmware, upgraded Yadis, no luck, upgraded the Dune to the latest beta firmware , no luck.

I appears related to the relative directory generated by Yadis. Series don't have any of those in them, so they work. Movies have a more complicated index, so relative dirs are used. However, grabbing the icon for the movie from a relative directory works, just media_url, action browse fails. Note that a fix should be in the latest beta firmware..


a section of dune_folder.txt for illustration:
in 00/00 there is

item.2.caption=MyMovie
item.2.media_action=browse
item.2.media_url=../99/MyMovie
item.2.icon_path=../99/MyMovie/icon.aai
item.2.icon_sel_path=../99/MyMovie/icon.aai
item.2.icon_scale_factor=0.85
item.2.icon_sel_scale_factor=1
item.2.icon_valign=center

in 00/00 there is a directory MyMovie
which contains a dune_folder containing
item.0.caption=Play
item.0.media_url=smb://<my NAS IP>/Movies/MyMovie/playlist.m3u


What is going on? Any ideas? What an I doing wrong here?

Fred-L
04-03-12, 19:05
In yaDIS, do a reset of the interface. Use the button at the top right hand corner (Advanced operations).
Then, re-process everything (movies and tv shows) and export.
Doing this should solve your issue.

woojen
04-03-12, 22:53
Fred-L,

Thank you for your quick response..

I tried just that, just re-tried that again, just to make sure, and it didn't solve the problem.

When I select Reset , in the top right of the interface, it tells me to re-process the movies and series, so I did that. I also hit the 'clear cache' button present in the same drop-down button.

After re-processing the movies, I deleted the contents of the index share on my NAS and had Yadis re-export the interface. I got a nice structure containing the movies, the saga and the tv showsI re-processed.

Using the Dune, I can browse to my tv shows , (only one now, for testing) and I can start an episode. I can also browse to the movie wall, which shows the saga and the movie I processed. I have movie/saga covers there, and I can see the selection change when I select next/previous on the remove, but 'OK' to go to a saga or view the details of a movie gets me an error box containing the following message
'Failed to open URL URL: nft-tcp://<nas IP>:index/00/99/MyMovie'
where index is the share name on the NAS.

The truly interesting part is that when I do 'Network Browser' --> SMB --> NAS --> Index' (which puts me basically in my yadis index), the index works just fine, I can see the Saga details as well as the movie details. However, at that point I cannot start anything, since the Dune tries to open a second SMB link, which, as we all know, is not possible.


Another idea would be greatly appreciated.

yannis
05-03-12, 09:41
I keep posting this in various threads - it needs to be made a sticky somehow. Anyway, for info, there is a way to get at your movies and yadis at the same time, without having to resort to NFS.

What you need to do is create a shared folder at the root of your NAS and call it something like "Media". Then move both your movie folders and the yadis folder into this. So your structue will look something like "NasName\Media\Movies" and "NasName\Media\Yadis". Then as far as the Dune is concerned, there is only a single network smb share which is "NasName\Media" but all your movies and yadis reside within it and are accessible at the same time.

Of course you can also create other folders within "Media" such as "TvShows" so you'd also have "NasName\Media\TV Shows" and it's still only the same smb share.

I doesn't explain why you have problems since upgrading to 2.2 but might be useful. Ref Yadis 2.2, do yoiu have latest Dune Beta firmware?

Fred-L
05-03-12, 09:50
woojen, it seems that you don't have the latest beta firmware on your Dune. This is the reason why you have problems with virtual items in dune_folder.txt.

woojen
05-03-12, 10:30
Hello Fred,

Thanks again for your ongoing support.

My dune is running 120202_1544_beta. As far as I know, this is the latest beta firmware available. I upgraded from 110606_1315 which is the latest stable version.

If there is a newer (beta) version available, please point me there.

Also interesting is the fact that when I access the index through SMB, the index works (apart from the fact that it then tries to create a new SMB connection to my Movies share, which, as we all know, fails due to Dune limitations)

I could 'invert' everything, and access the Index through SMB and the movies through NFS. I don't know if that will help.

woojen
05-03-12, 10:33
Hello yannis,

Thank you for your input. However, my Index and Movies shares are on different servers. Putting them on one server will be troublesome.

Fred-L
05-03-12, 11:03
Your firmware is ok. So this is not the reason of the issue.
Perhaps, you have an issue with the export process. As far as I understand you don't even see the synopsis screen of movies, right ? Can you check if you have these folders in the yaDIS's index on the Dune: "00\98" and "00\99" ? You can also check that on your PC in the folder "workspace\interface". The local index should be exactely the same as the one exported on the Dune.

woojen
05-03-12, 11:35
That is correct, I cannot see the synopsis screen of movies, or the 'saga' screen of sagas.

Both directories you mention are present in the Yadis index. As said before, when I use the network browser, and browse there through SMB, I can actually se the synosis screen. At that point I cannot start the movie since that would require a second smb connection to a NAS.

immetjes
05-03-12, 12:06
Shouldn't that be: nfs-tcp://<nas IP>:/index/00/99/MyMovie in stead of nft-tcp://<nas IP>:index/00/99/MyMovie

woojen
05-03-12, 12:11
immetjes,

That could be a typo by me, when copying the message from my TV..
Since I'm not at home, I cannot re-check this now. Will do that when I get home tonight.

Fred-L
05-03-12, 14:39
Regarding this:
in 00/00 there is a directory MyMovie
which contains a dune_folder containing
item.0.caption=Play
item.0.media_url=smb://<my NAS IP>/Movies/MyMovie/playlist.m3u
You should not have any directory in 00/00. This is the "All Movies" screen and the references to movies should only be in the dune_folder.txt that is on that directory. Only "00/99" should contain movie directories.
It seems that the reset of the interface did not work completely. You can do it yourself manually by deleting everything in "workspace\interface".

woojen
05-03-12, 18:12
I did that, and it still doesn't work.
00/00 does not contain movies, just a huge dune_folder.txt containing all movies & sagas.
00/98 contains the saga details
00/99 contains the movies, as you said.

I have swapped the config. The index is now accessed through SMB, while the movies are accessed using NFS. This appears to work, at least for my initial test movie.

woojen
06-03-12, 07:50
With the access protocols reversed, everything works, both for series as well as movies. It appears that having a relative share doesn't work properly when that relative directory is accessed through NFS.

Thanks for all suggestions.